DESIGNED DEVELOPED DELIVERED

Mob: 07760 392284edward@ee-web.co.uk

ee-web thinks... a bit

Go on, make my day ... leave a comment

Strict errors in Joomla 1.5 and no access to php.ini

May 6th, 2014 by Edward

Recently my host updated their php. This is good of course. However, I started seeing all, on some sites, a pile of  strict errors like this.

strict Standards: Non-static method JLoader::import() should not be called statically in …

It has taken hours to sort this out, and as ever with ‘debugging. its a one line fix. The newer php is getting cross because it has a higher (and therefore more secure) requirement on how well the php is written. Old code didn’t have to live up to this!

Anyway, like many people out there I have some reseller hosting which  means I can’t access php.ini I tried a whole pile of alterations in both the config and the .htaccess and got some angry responses in stackexchange.com telling me to dump clients!!!

Eventually I put this into the both the main index.php and the one within the administration folder.

After

define( ‘_JEXEC’, 1 );

add

error_reporting( E_ERROR | E_PARSE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING );

Imagine my unconstrained joy at seeing a normal login screen again!

categories

Edward owns and runs ee-web design and has been building websites for over 12 years. He is passionate about... most things really

Was this post helpful or interesting? Spread the news.

Leave a comment

*


tag